import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\S]*(?:\\[%)(\\w+)(?:%])(?:(?:[^\\S\\n]*=[^\\S\\n]*([^\\n]*[\\S])))?";
final String string = "[%Variable%]\n"
+ "[%Another_One%] = Lots of characters but no trailing spaces \n"
+ " [%MoreVariables_44%] = NotWhiteSpace Sensistive\n"
+ "[%NoBlanksAllowed%] = ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}