const regex = /[\S]*(?:\[%)(\w+)(?:%])(?:(?:[^\S\n]*=[^\S\n]*([^\n]*[\S])))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\S]*(?:\\[%)(\\w+)(?:%])(?:(?:[^\\S\\n]*=[^\\S\\n]*([^\\n]*[\\S])))?', 'gm')
const str = `[%Variable%]
[%Another_One%] = Lots of characters but no trailing spaces
[%MoreVariables_44%] = NotWhiteSpace Sensistive
[%NoBlanksAllowed%] = `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}