import Foundation
let pattern = #"(^\(\'\w+\'\,\s|\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"('InformationQueue_01_0000002a_03', [{'SystemTimeStr': '2000-00-00 00:00:00.0000', 'CHID': [], 'CHState': [], 'CHPower': [], 'CHTime': [], 'CHTimeModify': [], 'CHWaveModify': [], 'CHWaveCycle': [], 'CHlon': [], 'CHlat': [], 'CHalt': [], 'LocationType': '00', 'lat': 0.0, 'lon': 0.0, 'alt': 0.0, 'headerFlag': 'a0a1', 'loadLen': 34, 'BCCCheck': '8d', 'version': '01', 'deviceID': '0000002a', 'deviceType': '01', 'messageID': '03', 'header': 'a0a100228d010000002a0103', 'message': '07d00000000000000000000000017c2aa5a800000000000000000000000000000000'}]) "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)