using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\(\'\w+\'\,\s|\))";
string input = @"('InformationQueue_01_0000002a_03', [{'SystemTimeStr': '2000-00-00 00:00:00.0000', 'CHID': [], 'CHState': [], 'CHPower': [], 'CHTime': [], 'CHTimeModify': [], 'CHWaveModify': [], 'CHWaveCycle': [], 'CHlon': [], 'CHlat': [], 'CHalt': [], 'LocationType': '00', 'lat': 0.0, 'lon': 0.0, 'alt': 0.0, 'headerFlag': 'a0a1', 'loadLen': 34, 'BCCCheck': '8d', 'version': '01', 'deviceID': '0000002a', 'deviceType': '01', 'messageID': '03', 'header': 'a0a100228d010000002a0103', 'message': '07d00000000000000000000000017c2aa5a800000000000000000000000000000000'}]) ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}