$re = '/(^\(\'\w+\'\,\s|\))/m';
$str = '(\'InformationQueue_01_0000002a_03\', [{\'SystemTimeStr\': \'2000-00-00 00:00:00.0000\', \'CHID\': [], \'CHState\': [], \'CHPower\': [], \'CHTime\': [], \'CHTimeModify\': [], \'CHWaveModify\': [], \'CHWaveCycle\': [], \'CHlon\': [], \'CHlat\': [], \'CHalt\': [], \'LocationType\': \'00\', \'lat\': 0.0, \'lon\': 0.0, \'alt\': 0.0, \'headerFlag\': \'a0a1\', \'loadLen\': 34, \'BCCCheck\': \'8d\', \'version\': \'01\', \'deviceID\': \'0000002a\', \'deviceType\': \'01\', \'messageID\': \'03\', \'header\': \'a0a100228d010000002a0103\', \'message\': \'07d00000000000000000000000017c2aa5a800000000000000000000000000000000\'}]) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);