// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^\(\'\w+\'\,\s|\))").unwrap();
let string = "('InformationQueue_01_0000002a_03', [{'SystemTimeStr': '2000-00-00 00:00:00.0000', 'CHID': [], 'CHState': [], 'CHPower': [], 'CHTime': [], 'CHTimeModify': [], 'CHWaveModify': [], 'CHWaveCycle': [], 'CHlon': [], 'CHlat': [], 'CHalt': [], 'LocationType': '00', 'lat': 0.0, 'lon': 0.0, 'alt': 0.0, 'headerFlag': 'a0a1', 'loadLen': 34, 'BCCCheck': '8d', 'version': '01', 'deviceID': '0000002a', 'deviceType': '01', 'messageID': '03', 'header': 'a0a100228d010000002a0103', 'message': '07d00000000000000000000000017c2aa5a800000000000000000000000000000000'}]) ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}