// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?um)[A-Z][:][\\]([A-Za-z0-9])*([\\][A-Za-z0-9])*([\\]|[.[A-Za-z0-9]{1})*").unwrap();
let string = "D:\\western\\why\\what\\abc.exe
E:\\test.exe";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}