using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z][:][\\]([A-Za-z0-9])*([\\][A-Za-z0-9])*([\\]|[.[A-Za-z0-9]{1})*";
string input = @"D:\western\why\what\abc.exe
E:\test.exe";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}