$re = '/[A-Z][:][\\\\]([A-Za-z0-9])*([\\\\][A-Za-z0-9])*([\\\\]|[.[A-Za-z0-9]{1})*/um';
$str = 'D:\\western\\why\\what\\abc.exe
E:\\test.exe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);