re = /[A-Z][:][\\]([A-Za-z0-9])*([\\][A-Za-z0-9])*([\\]|[.[A-Za-z0-9]{1})*/m
str = 'D:\\western\\why\\what\\abc.exe
E:\\test.exe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end