import Foundation
let pattern = #"<Item TimeStamp="(?<timestamp>\d*:\d*:\d*.\d*)"[[:blank:]]Duration="(?<duration>\d*:\d*:\d*.\d*)"[[:blank:]]Line="(?<scriptline>\d*)"[[:blank:]]File="(?<scriptfilename>.*)"[[:blank:]]Command="(?<command_name>\w*)"[[:blank:]]Type="(?<severity>\w*)">(?<message>[\D]*)\t(?<time>\d*.\d*)<\/Item>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<Item TimeStamp="00:33:12.88" Duration="00:00:00.00" Line="87" File="all_test_v2.tws" Command="print" Type="Info">Loading Result screen time is: -1</Item>
<Item TimeStamp="00:32:32.10" Duration="00:00:00.00" Line="40" File="all_test_v2.tws" Command="print" Type="Info">Loading Search screen time 0.8045754</Item>
<Item TimeStamp="00:32:31.16" Duration="00:00:00.00" Line="28" File="all_test_v2.tws" Command="print" Type="Info">Loading Splash screen time is: 4.3964327</Item>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)