use strict;
my $str = '<Item TimeStamp="00:33:12.88" Duration="00:00:00.00" Line="87" File="all_test_v2.tws" Command="print" Type="Info">Loading Result screen time is: -1</Item>
<Item TimeStamp="00:32:32.10" Duration="00:00:00.00" Line="40" File="all_test_v2.tws" Command="print" Type="Info">Loading Search screen time 0.8045754</Item>
<Item TimeStamp="00:32:31.16" Duration="00:00:00.00" Line="28" File="all_test_v2.tws" Command="print" Type="Info">Loading Splash screen time is: 4.3964327</Item>
';
my $regex = qr/<Item TimeStamp="(?<timestamp>\d*:\d*:\d*.\d*)"[[:blank:]]Duration="(?<duration>\d*:\d*:\d*.\d*)"[[:blank:]]Line="(?<scriptline>\d*)"[[:blank:]]File="(?<scriptfilename>.*)"[[:blank:]]Command="(?<command_name>\w*)"[[:blank:]]Type="(?<severity>\w*)">(?<message>[\D]*)\t(?<time>\d*.\d*)<\/Item>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}