# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<Item TimeStamp=\"(?<timestamp>\d*:\d*:\d*.\d*)\"[[:blank:]]Duration=\"(?<duration>\d*:\d*:\d*.\d*)\"[[:blank:]]Line=\"(?<scriptline>\d*)\"[[:blank:]]File=\"(?<scriptfilename>.*)\"[[:blank:]]Command=\"(?<command_name>\w*)\"[[:blank:]]Type=\"(?<severity>\w*)\">(?<message>[\D]*)\t(?<time>\d*.\d*)<\/Item>"
test_str = ("<Item TimeStamp=\"00:33:12.88\" Duration=\"00:00:00.00\" Line=\"87\" File=\"all_test_v2.tws\" Command=\"print\" Type=\"Info\">Loading Result screen time is: -1</Item>\n\n"
"<Item TimeStamp=\"00:32:32.10\" Duration=\"00:00:00.00\" Line=\"40\" File=\"all_test_v2.tws\" Command=\"print\" Type=\"Info\">Loading Search screen time 0.8045754</Item>\n\n"
"<Item TimeStamp=\"00:32:31.16\" Duration=\"00:00:00.00\" Line=\"28\" File=\"all_test_v2.tws\" Command=\"print\" Type=\"Info\">Loading Splash screen time is: 4.3964327</Item>\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.