$re = '/<Item TimeStamp="(?<timestamp>\d*:\d*:\d*.\d*)"[[:blank:]]Duration="(?<duration>\d*:\d*:\d*.\d*)"[[:blank:]]Line="(?<scriptline>\d*)"[[:blank:]]File="(?<scriptfilename>.*)"[[:blank:]]Command="(?<command_name>\w*)"[[:blank:]]Type="(?<severity>\w*)">(?<message>[\D]*)\t(?<time>\d*.\d*)<\/Item>/';
$str = '<Item TimeStamp="00:33:12.88" Duration="00:00:00.00" Line="87" File="all_test_v2.tws" Command="print" Type="Info">Loading Result screen time is: -1</Item>
<Item TimeStamp="00:32:32.10" Duration="00:00:00.00" Line="40" File="all_test_v2.tws" Command="print" Type="Info">Loading Search screen time 0.8045754</Item>
<Item TimeStamp="00:32:31.16" Duration="00:00:00.00" Line="28" File="all_test_v2.tws" Command="print" Type="Info">Loading Splash screen time is: 4.3964327</Item>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);