use strict;
my $str = '(RA-B) RA-B三室两卫
(RA-B(NOC)) RA-B-NOC三室两卫
(RA-A) RA-A三室两卫
(RA-A(T)) RA-A(T)三室两卫
(more wicked) example
(WTF CODE CONTAINS WHITESPACES!) still it works
This (violates) the rule.
(Needs a whitespace)after the parenthesis.
((Nested) parentheses) causes unexpected results.
(Badly (paired) parentheses ain\'t my fault.';
my $regex = qr/^\s*\((.+?)\)(?: .*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}