using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*\((.+?)\)(?: .*)$";
string input = @"(RA-B) RA-B三室两卫
(RA-B(NOC)) RA-B-NOC三室两卫
(RA-A) RA-A三室两卫
(RA-A(T)) RA-A(T)三室两卫
(more wicked) example
(WTF CODE CONTAINS WHITESPACES!) still it works
This (violates) the rule.
(Needs a whitespace)after the parenthesis.
((Nested) parentheses) causes unexpected results.
(Badly (paired) parentheses ain't my fault.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}