package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*\((.+?)\)(?: .*)$`)
var str = `(RA-B) RA-B三室两卫
(RA-B(NOC)) RA-B-NOC三室两卫
(RA-A) RA-A三室两卫
(RA-A(T)) RA-A(T)三室两卫
(more wicked) example
(WTF CODE CONTAINS WHITESPACES!) still it works
This (violates) the rule.
(Needs a whitespace)after the parenthesis.
((Nested) parentheses) causes unexpected results.
(Badly (paired) parentheses ain't my fault.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}