const regex = new RegExp('^\\s*\\((.+?)\\)(?: .*)$', 'gm')
const str = `(RA-B) RA-B三室两卫
(RA-B(NOC)) RA-B-NOC三室两卫
(RA-A) RA-A三室两卫
(RA-A(T)) RA-A(T)三室两卫
(more wicked) example
(WTF CODE CONTAINS WHITESPACES!) still it works
This (violates) the rule.
(Needs a whitespace)after the parenthesis.
((Nested) parentheses) causes unexpected results.
(Badly (paired) parentheses ain't my fault.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}