import Foundation
let pattern = #"\d+\K\d{3}(?=\h£)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2015 64 Fiat 500 S Hatchback 1.2 Manual Petrol Silver White 13000 £7,495
2012 12 Fiat 500 Lounge Hatchback 1.2 Manual Petrol White 9000 £5,495
2014 14 Fiat Panda Pop Hatchback 1.2 Manual Petrol White 30000 £4,695
2009 09 Fiat 500 Pop Hatchback 1.2 Manual Petrol Yellow 31000 £4,295
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #",$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)