# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+\K\d{3}(?=\h£)/,$0/g;t' <<< "2015 64 Fiat 500 S Hatchback 1.2 Manual Petrol Silver White 13000 £7,495
2012 12 Fiat 500 Lounge Hatchback 1.2 Manual Petrol White 9000 £5,495
2014 14 Fiat Panda Pop Hatchback 1.2 Manual Petrol White 30000 £4,695
2009 09 Fiat 500 Pop Hatchback 1.2 Manual Petrol Yellow 31000 £4,295"