import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\K\\d{3}(?=\\h£)";
final String string = "2015 64 Fiat 500 S Hatchback 1.2 Manual Petrol Silver White 13000 £7,495\n"
+ "2012 12 Fiat 500 Lounge Hatchback 1.2 Manual Petrol White 9000 £5,495\n"
+ "2014 14 Fiat Panda Pop Hatchback 1.2 Manual Petrol White 30000 £4,695\n"
+ "2009 09 Fiat 500 Pop Hatchback 1.2 Manual Petrol Yellow 31000 £4,295";
final String subst = ",$0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}