$re = '/^([A-Za-zÀ-ÖØ-öø-ú]+) ((?:(?:[D-d]e|[D-d]a|[D-d]o|[D-d]as|[D-d]os|[E-e]m|[E-e]|[D-d]el|[E-e]l)\s(?:[A-Za-zÀ-ÖØ-öø-ú]+))|(?:[A-Za-zÀ-ÖØ-öø-ú]+))/im';
$str = 'Mauro del silva';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);