#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^([A-Za-zÀ-ÖØ-öø-ú]+) ((?:(?:[D-d]e|[D-d]a|[D-d]o|[D-d]as|[D-d]os|[E-e]m|[E-e]|[D-d]el|[E-e]l)\s(?:[A-Za-zÀ-ÖØ-öø-ú]+))|(?:[A-Za-zÀ-ÖØ-öø-ú]+))"
Local $sString = "Mauro del silva"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")