import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Za-zÀ-ÖØ-öø-ú]+) ((?:(?:[D-d]e|[D-d]a|[D-d]o|[D-d]as|[D-d]os|[E-e]m|[E-e]|[D-d]el|[E-e]l)\\s(?:[A-Za-zÀ-ÖØ-öø-ú]+))|(?:[A-Za-zÀ-ÖØ-öø-ú]+))";
final String string = "Mauro del silva";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}