package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^([A-Za-zÀ-ÖØ-öø-ú]+) ((?:(?:[D-d]e|[D-d]a|[D-d]o|[D-d]as|[D-d]os|[E-e]m|[E-e]|[D-d]el|[E-e]l)\s(?:[A-Za-zÀ-ÖØ-öø-ú]+))|(?:[A-Za-zÀ-ÖØ-öø-ú]+))`)
var str = `Mauro del silva`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}