re = /(?>[^\"\(\s\)]+(?>(?>\"[^\"]*\")[^\"\(\s\)]*)*)|(?>[^\"\(\s\)]*(?>(?>\"[^\"]*\")[^\"\(\s\)]*)+)/
str = '123
"a b c"
f"Hello, {world}!"
"multi-line
strings"
text-before-the-quote"text in the quote"text-after-the-quote
[]{}<>-are-also"atoms since we only care about ()"<-notice_we_had_to_escape"("and")"
emoji.too:🗿:😂'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end