$re = '/(?>[^\"\(\s\)]+(?>(?>\"[^\"]*\")[^\"\(\s\)]*)*)|(?>[^\"\(\s\)]*(?>(?>\"[^\"]*\")[^\"\(\s\)]*)+)/';
$str = '123
"a b c"
f"Hello, {world}!"
"multi-line
strings"
text-before-the-quote"text in the quote"text-after-the-quote
[]{}<>-are-also"atoms since we only care about ()"<-notice_we_had_to_escape"("and")"
emoji.too:🗿:😂';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);