#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?>[^\"\(\s\)]+(?>(?>\"[^\"]*\")[^\"\(\s\)]*)*)|(?>[^\"\(\s\)]*(?>(?>\"[^\"]*\")[^\"\(\s\)]*)+)"
Local $sString = "123" & @CRLF & _
"" & @CRLF & _
""a b c"" & @CRLF & _
"" & @CRLF & _
"f"Hello, {world}!"" & @CRLF & _
"" & @CRLF & _
""multi-line" & @CRLF & _
"strings"" & @CRLF & _
"" & @CRLF & _
"text-before-the-quote"text in the quote"text-after-the-quote" & @CRLF & _
"" & @CRLF & _
"[]{}<>-are-also"atoms since we only care about ()"<-notice_we_had_to_escape"("and")"" & @CRLF & _
"" & @CRLF & _
"emoji.too:🗿:😂"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")