using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?>[^\""\(\s\)]+(?>(?>\""[^\""]*\"")[^\""\(\s\)]*)*)|(?>[^\""\(\s\)]*(?>(?>\""[^\""]*\"")[^\""\(\s\)]*)+)";
string input = @"123
""a b c""
f""Hello, {world}!""
""multi-line
strings""
text-before-the-quote""text in the quote""text-after-the-quote
[]{}<>-are-also""atoms since we only care about ()""<-notice_we_had_to_escape""(""and"")""
emoji.too:🗿:😂";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}