// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[\w+'\.\-\s]*?([\w'-]+))(?:,.*?)*? tells the group, 'blah'$").unwrap();
let string = "Magi-cal Prin'cess Sab'ri-ne, the dragon violating sorceresss tells the group, 'blah'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}