const regex = /^(?:[\w+'\.\-\s]*?([\w'-]+))(?:,.*?)*? tells the group, 'blah'$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[\\w+\'\\.\\-\\s]*?([\\w\'-]+))(?:,.*?)*? tells the group, \'blah\'$', 'gm')
const str = `Magi-cal Prin'cess Sab'ri-ne, the dragon violating sorceresss tells the group, 'blah'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}