$re = '/^(?:[\w+\'\.\-\s]*?([\w\'-]+))(?:,.*?)*? tells the group, \'blah\'$/m';
$str = 'Magi-cal Prin\'cess Sab\'ri-ne, the dragon violating sorceresss tells the group, \'blah\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);