re = /^(?:[\w+'\.\-\s]*?([\w'-]+))(?:,.*?)*? tells the group, 'blah'$/m
str = 'Magi-cal Prin\'cess Sab\'ri-ne, the dragon violating sorceresss tells the group, \'blah\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end