use strict;
my $str = '```js
var test = \'test\';
```
```js
var x = "John Doe";
console.log( x );
```';
my $regex = qr/^ {0,3}((?:(`){3,}?)|(?:(~){3,}?))(?!\2\3)(?:([^`\n]+?)(\1(?:\2\3)*)|(?:( *([^ \n]+)[^`\n]*)?\n([\s\S]*?)(^ {0,3}))(\1(?:\2\3)*)(?=$))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}