import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ {0,3}((?:(`){3,}?)|(?:(~){3,}?))(?!\\2\\3)(?:([^`\\n]+?)(\\1(?:\\2\\3)*)|(?:( *([^ \\n]+)[^`\\n]*)?\\n([\\s\\S]*?)(^ {0,3}))(\\1(?:\\2\\3)*)(?=$))";
final String string = "```js\n"
+ "var test = 'test';\n"
+ "```\n\n"
+ "```js\n"
+ "var x = \"John Doe\";\n"
+ "console.log( x );\n"
+ "```";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}