const regex = /^ {0,3}((?:(`){3,}?)|(?:(~){3,}?))(?!\2\3)(?:([^`\n]+?)(\1(?:\2\3)*)|(?:( *([^ \n]+)[^`\n]*)?\n([\s\S]*?)(^ {0,3}))(\1(?:\2\3)*)(?=$))/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ {0,3}((?:(`){3,}?)|(?:(~){3,}?))(?!\\2\\3)(?:([^`\\n]+?)(\\1(?:\\2\\3)*)|(?:( *([^ \\n]+)[^`\\n]*)?\\n([\\s\\S]*?)(^ {0,3}))(\\1(?:\\2\\3)*)(?=$))', 'mg')
const str = `\`\`\`js
var test = 'test';
\`\`\`
\`\`\`js
var x = "John Doe";
console.log( x );
\`\`\``;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}