using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ {0,3}((?:(`){3,}?)|(?:(~){3,}?))(?!\2\3)(?:([^`\n]+?)(\1(?:\2\3)*)|(?:( *([^ \n]+)[^`\n]*)?\n([\s\S]*?)(^ {0,3}))(\1(?:\2\3)*)(?=$))";
string input = @"```js
var test = 'test';
```
```js
var x = ""John Doe"";
console.log( x );
```";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}