import Foundation
let pattern = #"(url\(\\?['"]?)(.*?)(\\?['"]?\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
/* stylelint-disable indentation */
/// Plasma design theme icons
@font-face {
@include font-weight(regular);
font-family: 'custom-icons';
font-style: normal;
src: url(\"/assets/img/raster-matrix-top-to-bottom.svg\")
format('woff'),
url('~@com.mgmtp.a12/plasma-design/assets/fonts/customicons/custom-icons.ttf')
format('truetype');
}
/// Material design icons
@font-face {
@include font-weight(regular);
font-family: 'Material Icons';
font-style: normal;
src: url('/assets/fonts/material-design-icons/MaterialIcons-Regular.eot')
format('eot'),
url('/assets/fonts/material-design-icons/MaterialIcons-Regular.woff2')
format('woff2'),
url('/assets/fonts/material-design-icons/MaterialIcons-Regular.woff')
format('woff'),
url('/assets/fonts/material-design-icons/MaterialIcons-Regular.ttf')
format('truetype');
}
/// Avenir
/// Regular
@font-face {
@include font-weight(regular);
font-family: 'Avenir';
font-style: normal;
src: url(\"/assets/img/raster-matrix-top-to-bottom.svg\") format('eot'),
url('/assets/fonts/avenir/avenir-regular.woff2') format('woff2'),
url('/assets/fonts/avenir/avenir-regular.woff') format('woff'),
url('/assets/fonts/avenir/avenir-regular.ttf') format('truetype');
}
/// Avenir
/// Demi
@font-face {
@include font-weight(demi);
font-family: 'Avenir';
font-style: normal;
src: url('/assets/fonts/avenir/avenir-demi.eot') format('eot'),
url('/assets/fonts/avenir/avenir-demi.woff2') format('woff2'),
url('/assets/fonts/avenir/avenir-demi.woff') format('woff'),
url('/assets/fonts/avenir/avenir-demi.ttf') format('truetype');
}
/// Avenir
/// Medium
@font-face {
@include font-weight(medium);
font-family: 'Avenir';
font-style: normal;
src: url('/assets/fonts/avenir/avenir-medium.eot') format('eot'),
url('/assets/fonts/avenir/avenir-medium.woff2') format('woff2'),
url('/assets/fonts/avenir/avenir-medium.woff') format('woff'),
url('/assets/fonts/avenir/avenir-medium.ttf') format('truetype');
}
/* stylelint-enable indentation */
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)