// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)(url\(\\?['"]?)(.*?)(\\?['"]?\))"#).unwrap();
let string = "/* stylelint-disable indentation */
/// Plasma design theme icons
@font-face {
@include font-weight(regular);
font-family: 'custom-icons';
font-style: normal;
src: url(\\\"/assets/img/raster-matrix-top-to-bottom.svg\\\")
format('woff'),
url('~@com.mgmtp.a12/plasma-design/assets/fonts/customicons/custom-icons.ttf')
format('truetype');
}
/// Material design icons
@font-face {
@include font-weight(regular);
font-family: 'Material Icons';
font-style: normal;
src: url('/assets/fonts/material-design-icons/MaterialIcons-Regular.eot')
format('eot'),
url('/assets/fonts/material-design-icons/MaterialIcons-Regular.woff2')
format('woff2'),
url('/assets/fonts/material-design-icons/MaterialIcons-Regular.woff')
format('woff'),
url('/assets/fonts/material-design-icons/MaterialIcons-Regular.ttf')
format('truetype');
}
/// Avenir
/// Regular
@font-face {
@include font-weight(regular);
font-family: 'Avenir';
font-style: normal;
src: url(\\\"/assets/img/raster-matrix-top-to-bottom.svg\\\") format('eot'),
url('/assets/fonts/avenir/avenir-regular.woff2') format('woff2'),
url('/assets/fonts/avenir/avenir-regular.woff') format('woff'),
url('/assets/fonts/avenir/avenir-regular.ttf') format('truetype');
}
/// Avenir
/// Demi
@font-face {
@include font-weight(demi);
font-family: 'Avenir';
font-style: normal;
src: url('/assets/fonts/avenir/avenir-demi.eot') format('eot'),
url('/assets/fonts/avenir/avenir-demi.woff2') format('woff2'),
url('/assets/fonts/avenir/avenir-demi.woff') format('woff'),
url('/assets/fonts/avenir/avenir-demi.ttf') format('truetype');
}
/// Avenir
/// Medium
@font-face {
@include font-weight(medium);
font-family: 'Avenir';
font-style: normal;
src: url('/assets/fonts/avenir/avenir-medium.eot') format('eot'),
url('/assets/fonts/avenir/avenir-medium.woff2') format('woff2'),
url('/assets/fonts/avenir/avenir-medium.woff') format('woff'),
url('/assets/fonts/avenir/avenir-medium.ttf') format('truetype');
}
/* stylelint-enable indentation */
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}