use strict;
my $str = '/* stylelint-disable indentation */
/// Plasma design theme icons
@font-face {
@include font-weight(regular);
font-family: \'custom-icons\';
font-style: normal;
src: url(\\"/assets/img/raster-matrix-top-to-bottom.svg\\")
format(\'woff\'),
url(\'~@com.mgmtp.a12/plasma-design/assets/fonts/customicons/custom-icons.ttf\')
format(\'truetype\');
}
/// Material design icons
@font-face {
@include font-weight(regular);
font-family: \'Material Icons\';
font-style: normal;
src: url(\'/assets/fonts/material-design-icons/MaterialIcons-Regular.eot\')
format(\'eot\'),
url(\'/assets/fonts/material-design-icons/MaterialIcons-Regular.woff2\')
format(\'woff2\'),
url(\'/assets/fonts/material-design-icons/MaterialIcons-Regular.woff\')
format(\'woff\'),
url(\'/assets/fonts/material-design-icons/MaterialIcons-Regular.ttf\')
format(\'truetype\');
}
/// Avenir
/// Regular
@font-face {
@include font-weight(regular);
font-family: \'Avenir\';
font-style: normal;
src: url(\\"/assets/img/raster-matrix-top-to-bottom.svg\\") format(\'eot\'),
url(\'/assets/fonts/avenir/avenir-regular.woff2\') format(\'woff2\'),
url(\'/assets/fonts/avenir/avenir-regular.woff\') format(\'woff\'),
url(\'/assets/fonts/avenir/avenir-regular.ttf\') format(\'truetype\');
}
/// Avenir
/// Demi
@font-face {
@include font-weight(demi);
font-family: \'Avenir\';
font-style: normal;
src: url(\'/assets/fonts/avenir/avenir-demi.eot\') format(\'eot\'),
url(\'/assets/fonts/avenir/avenir-demi.woff2\') format(\'woff2\'),
url(\'/assets/fonts/avenir/avenir-demi.woff\') format(\'woff\'),
url(\'/assets/fonts/avenir/avenir-demi.ttf\') format(\'truetype\');
}
/// Avenir
/// Medium
@font-face {
@include font-weight(medium);
font-family: \'Avenir\';
font-style: normal;
src: url(\'/assets/fonts/avenir/avenir-medium.eot\') format(\'eot\'),
url(\'/assets/fonts/avenir/avenir-medium.woff2\') format(\'woff2\'),
url(\'/assets/fonts/avenir/avenir-medium.woff\') format(\'woff\'),
url(\'/assets/fonts/avenir/avenir-medium.ttf\') format(\'truetype\');
}
/* stylelint-enable indentation */
';
my $regex = qr/(url\(\\?['"]?)(.*?)(\\?['"]?\))/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}