#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(url\(\\?['"]?)(.*?)(\\?['"]?\))"
Local $sString = "/* stylelint-disable indentation */" & @CRLF & _
"" & @CRLF & _
"/// Plasma design theme icons" & @CRLF & _
"@font-face {" & @CRLF & _
" @include font-weight(regular);" & @CRLF & _
" font-family: 'custom-icons';" & @CRLF & _
" font-style: normal;" & @CRLF & _
" src: url(\"/assets/img/raster-matrix-top-to-bottom.svg\")" & @CRLF & _
" format('woff')," & @CRLF & _
" url('~@com.mgmtp.a12/plasma-design/assets/fonts/customicons/custom-icons.ttf')" & @CRLF & _
" format('truetype');" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"/// Material design icons" & @CRLF & _
"@font-face {" & @CRLF & _
" @include font-weight(regular);" & @CRLF & _
" font-family: 'Material Icons';" & @CRLF & _
" font-style: normal;" & @CRLF & _
" src: url('/assets/fonts/material-design-icons/MaterialIcons-Regular.eot')" & @CRLF & _
" format('eot')," & @CRLF & _
" url('/assets/fonts/material-design-icons/MaterialIcons-Regular.woff2')" & @CRLF & _
" format('woff2')," & @CRLF & _
" url('/assets/fonts/material-design-icons/MaterialIcons-Regular.woff')" & @CRLF & _
" format('woff')," & @CRLF & _
" url('/assets/fonts/material-design-icons/MaterialIcons-Regular.ttf')" & @CRLF & _
" format('truetype');" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"/// Avenir" & @CRLF & _
"/// Regular" & @CRLF & _
"@font-face {" & @CRLF & _
" @include font-weight(regular);" & @CRLF & _
" font-family: 'Avenir';" & @CRLF & _
" font-style: normal;" & @CRLF & _
" src: url(\"/assets/img/raster-matrix-top-to-bottom.svg\") format('eot')," & @CRLF & _
" url('/assets/fonts/avenir/avenir-regular.woff2') format('woff2')," & @CRLF & _
" url('/assets/fonts/avenir/avenir-regular.woff') format('woff')," & @CRLF & _
" url('/assets/fonts/avenir/avenir-regular.ttf') format('truetype');" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"/// Avenir" & @CRLF & _
"/// Demi" & @CRLF & _
"@font-face {" & @CRLF & _
" @include font-weight(demi);" & @CRLF & _
" font-family: 'Avenir';" & @CRLF & _
" font-style: normal;" & @CRLF & _
" src: url('/assets/fonts/avenir/avenir-demi.eot') format('eot')," & @CRLF & _
" url('/assets/fonts/avenir/avenir-demi.woff2') format('woff2')," & @CRLF & _
" url('/assets/fonts/avenir/avenir-demi.woff') format('woff')," & @CRLF & _
" url('/assets/fonts/avenir/avenir-demi.ttf') format('truetype');" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"/// Avenir" & @CRLF & _
"/// Medium" & @CRLF & _
"@font-face {" & @CRLF & _
" @include font-weight(medium);" & @CRLF & _
" font-family: 'Avenir';" & @CRLF & _
" font-style: normal;" & @CRLF & _
" src: url('/assets/fonts/avenir/avenir-medium.eot') format('eot')," & @CRLF & _
" url('/assets/fonts/avenir/avenir-medium.woff2') format('woff2')," & @CRLF & _
" url('/assets/fonts/avenir/avenir-medium.woff') format('woff')," & @CRLF & _
" url('/assets/fonts/avenir/avenir-medium.ttf') format('truetype');" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"/* stylelint-enable indentation */" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")