// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(-?[pm][tbrlxy]?-)([248]){1} ").unwrap();
let string = "p-8
pt-4
m-2
mx-4
-ml-4 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}