import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(-?[pm][tbrlxy]?-)([248]){1} ";
final String string = "p-8 \n"
+ "pt-4 \n"
+ "m-2 \n"
+ "mx-4 \n"
+ "-ml-4 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}