using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(-?[pm][tbrlxy]?-)([248]){1} ";
string input = @"p-8
pt-4
m-2
mx-4
-ml-4 ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}