$re = '/(-?[pm][tbrlxy]?-)([248]){1} /';
$str = 'p-8
pt-4
m-2
mx-4
-ml-4 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);