import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((([0][1-9]|1\\d)|2[0-9])|(([12]\\d|0[1-9])|(3[01]))(?!\\.02))\\.(0[1-9]|1[0-2])\\.(\\d{4}|\\d{2}))\n"
+ "|\n"
+ "((0(1|[3-9])|1[0-2])\\.(0[1-9]|[12]\\d|3[01])|02\\.([1-9]|[12]\\d))\\.(\\d{4}|\\d{2})";
final String string = "Ftet30.02.1999\n"
+ "29.02.1999\n"
+ "28.03.1999\n"
+ "01.02.1999\n"
+ "29.00.1123\n"
+ "00.00.1999\n"
+ "01.01.11_+L12.22.2121\n"
+ "02.28.1111\n"
+ "01.12\n"
+ "09.18.1r11.30.67\n\n"
+ "Ftet30.02.1999\n\n"
+ "01.01.11_+L12.22.2121\n"
+ "02.30.11\n"
+ "03.30.11\n"
+ "02.29.11\n"
+ "02.30.12\n"
+ "02.10.12\n\n"
+ "09.18.1r11.30.67\n\n"
+ "Ftet30.02.1999\n\n"
+ "01.01.11_+L12.22.2121\n\n"
+ "09.18.1r11.30.67";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}