re = /XS( ?)(?<perc>[0-9]+(\.[0-9]+)?) (?<time>[0-9]+(\\.[0-9]+)?)/
str = 'XS 10.1 100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end