$re = '/XS( ?)(?<perc>[0-9]+(\.[0-9]+)?) (?<time>[0-9]+(\\\\.[0-9]+)?)/';
$str = 'XS 10.1 100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);