package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`XS( ?)(?<perc>[0-9]+(\.[0-9]+)?) (?<time>[0-9]+(\\.[0-9]+)?)`)
var str = `XS 10.1 100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}