using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"XS( ?)(?<perc>[0-9]+(\.[0-9]+)?) (?<time>[0-9]+(\\.[0-9]+)?)";
string input = @"XS 10.1 100";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}